CubieBoard vs RaspberryPiThis week has been full of unexpected surprises.  I finally received the Cubieboard I had order several weeks ago.  I think I paid $59 + shipping for the kit which came with a case, cords and a cardboard box similar to the original boxes that Raspberry Pi’s were shipped in.  I didn’t have high expectations for the device to be honest because my only exposure to them has been people having problems compiling openzwave on the Raspbian that was mangled to work on the Cubieboard.

Another area of concern, the documentation online for the Cubieboard is horrible compared to the documentation and community available to Raspberry Pi owners.  The strangest thing for me is I don’t know which is the official forum.  There are two links to two different forums on the main Cubieboard site and most of those posts link to another AllWinner board.

Back to the packaging, it was actually really nice.  It had inner boxes with more inner boxes and nicely custom cut foam.  The only thing it was missing was the “designed in Cupertino” on the side of the box.

When I pulled it out and went searching on the web for the amps needed for the supplied usb power cord, I learned that this bad boy has 4G of NAND memory with Android already loaded on it (yeah, I am an idiot for not knowing that ahead of time).

I know I should have removed the paper.

I know I should have removed the paper.

I was shocked.  In a good way.  I thought I would have to spend a couple hours fighting to get the perfect image on a micro sd card to even get to see the thing in action (something I knew I didn’t have time for today).  Instead all I had to do was plug in power, hdmi, and a hub for the mouse, keyboard, and wireless (super cheap dongle worked immediately).  Best of all, once I had it plugged in it looked like Christmas with bright green and red leds.  Wonderful.

Then surprise two: it didn’t dawn on me that this is just a giant tablet.  It runs almost all tablet apps from the Play store including the most bullshit Comcast app.  The Comcast app does not let you use airplay to extend your content onto a larger screen due to ridiculous DRM standards (and even though the dialog box on Apple even says ‘stream anything you can see on your iPad to your Apple TV’).  It was so glorious to defeat Comcast and watch the shows on the big screen, I left it streaming anything and everything the rest of the day.  Tomorrow, I plan on having Entourage going in the background while I get some work done.

Now I haven’t gotten to the real use of this toy yet.  The evaluation is completely premature but after day one, I have to say this is better and easier  to use than the Raspberry Pi.  People can ease in to making disk images but still have something to play with while they are learning.

Another nice thing is the fact that the case and cords are included.  Then when you look at speed, RAM, SATA connections 4g NAND,  and the fact that your ethernet that does not compete with your usb devices….. I am really starting to like this.  Let’s see how day two goes.

Forgot to mention – plugged in my cheap wifi dongle and it just worked.  Way to go Android.

Day 2 Update

Still impressed.  I followed a nice tutorial to get a minimal Debian Wheezy install up and running from a micro SD card.  The process is very similar to the Raspberry Pi experience but their are a few extra steps because so many devices share the same distro.  After writing the distro to your SD card, you have to write the device-specific bootloader.  In my case, the /dev/sdX was /dev/mmcblk0.  When you write your images you will see two partitions – just like the Raspberry Pi.  For a quick test, I ran ‘sysbench –test=cpu –cpu-max-prime=20000 run’ on the new install and got an average total time of 656.2975 seconds to complete the test.  I am not sure how that number compares to other Cubieboards / Cubieboard distros.  A lot of forums talk about the need to tweak the cpu to run more like a server and less like a tablet but I have not ventured down that road yet.  As a quick comparison, my GitPi did the same sysbench test in 1320.0708 seconds and 1081.8397 seconds on an OpenZ-wave test Pi.

If you want to install sysbench, you can get it from the repo with ‘sudo apt-get install sysbench’.


Comments

  1. Dave Appleton -

    Hi – which wifi dongle did you use for Android?

    Reply

Leave a Reply